DHL Global Outage

Incident Report for nShift

Resolved

Although we haven't heard from DHL, requests have been going through for the last hour. We consider this incident over.
Posted Dec 10, 2025 - 19:02 CET

Update

We see DHL products are back on and there have been no issues for the last 15 minutes. We will keep monitoring.
Posted Dec 10, 2025 - 18:13 CET

Monitoring

DHL is experiencing a major outage. Most of their services are affected.
We are in contact with DHL and will update with further information as it becomes available.
Posted Dec 10, 2025 - 17:45 CET
This incident affected: Ship Carrier Connections (DHL, DHL Express, DHL Parcel Germany).