CarrierServer having some issues and timing out for API carriers

Incident Report for nShift - Ship & Track

Resolved

Incident resolved, and everything is back to normal operations.

We will provide more details separately if needed.
Posted Jun 05, 2025 - 17:01 CEST

Monitoring

UPDATE - We have stabilised the system and are starting to scale back while we continue to monitor the situation. We will establish and publish a root cause in due process.
Posted Jun 05, 2025 - 15:59 CEST

Update

UPDATE - We have added machines and are seeing more stability, reducing the timeout time, but this is till to high for most carriers. We are continuing to work to reduce this timeout time.
Posted Jun 05, 2025 - 15:05 CEST

Investigating

We are currently investigating the issue!
Posted Jun 05, 2025 - 14:04 CEST
This incident affected: Carrier Connections (Carrier Connections, Carrier Server), Checkout, and Ship (Rest API v1, Rest API v2, Ticket, Klarna, Message Hub (Drop Zone)).