We have seen no more issues for more than 30 minutes now. Will continue to monitor but the issue can be considered closed.
All API calls are responding in great times. There will be a lessons learned and RCA document in the following days.
For now the AWS caused most of these issues with their global disruption and we will work on ways to prevent issues reflecting on our end in the future.
Posted Oct 20, 2025 - 14:22 CEST
Update
According to AWS status page Amazon is still working on fully recovering AWS issues. However we now seem to have all affected services on our side stabilized and we see response times are back to normal.
We continue monitoring the situation closely.
Posted Oct 20, 2025 - 13:47 CEST
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 12:56 CEST
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 12:14 CEST
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 12:13 CEST
Monitoring
We have experienced intermittent disruptions to our production systems due to operational challenges at AWS, including issues affecting the service provider hosting our System Status page. Carriers are also impacted by the ongoing AWS-related issues.