Portal is slow and timing out

Incident Report for nShift - Ship & Track

Resolved

No further issues after the issue was fixed.
Closing incident
Posted Jul 30, 2025 - 15:20 CEST

Monitoring

The issue has been resolved.
We are monitoring to make sure the service remains stable after the fix.
Posted Jul 30, 2025 - 12:55 CEST

Investigating

We have received reports that nshiftportal.com is slow and giving timeouts.
We are working on fixing the issue as soon as possible
Posted Jul 30, 2025 - 11:35 CEST
This incident affected: Track (Track Dashboard).