Issues with nShift Delivery DNS affecting DHL services

Incident Report for nShift

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 09:06 CET

Monitoring

DNS problems towards DHL resolved around 16:36, we'll continue monitoring and provide another update tomorrow around 9:00. Thank you for your patience and understanding.
Posted Dec 11, 2025 - 16:55 CET

Investigating

DHL issues with DNS are persisting on our side, we are investigating.
Posted Dec 11, 2025 - 15:31 CET
This incident affected: Delivery.