nShift Portal

Incident Report for nShift

Resolved

This incident has been resolved.
Posted May 28, 2026 - 10:44 CEST

Monitoring

A fix has been implemented and we are monitoring. nShift Portal should now be accessible.
Posted May 28, 2026 - 10:27 CEST

Investigating

nShift Portal is currently experiencing issues. We are aware and our engineers are working on a fix.
Posted May 28, 2026 - 10:26 CEST